Back to overview
Resolved

cPanel licensing issue resolved

Jul 8, 2026 at 11:16pm UTC
Affected services
web20.hosting-cloud.net:2087
web23.hosting-cloud.net:2087
web25.hosting-cloud.net:2087
web26.hosting-cloud.net:2087
web27.hosting-cloud.net:2087
web28.hosting-cloud.net:2087
web30.hosting-cloud.net:2087
web31.hosting-cloud.net:2087
web32.hosting-cloud.net:2087
web34.hosting-cloud.net:2087
web35.hosting-cloud.net:2087
web38.hosting-cloud.net:2087
web41.hosting-cloud.net:2087
web42.hosting-cloud.net:2087
web43.hosting-cloud.net:2087
web44.hosting-cloud.net:2087
web45.hosting-cloud.net:2087
web59.hosting-cloud.net:2087
web62.hosting-cloud.net:2087
web64.hosting-cloud.net:2087
web65.hosting-cloud.net:2087
web66.hosting-cloud.net:2087
web67.hosting-cloud.net:2087
web72.hosting-cloud.net:2087
web74.hosting-cloud.net:2087
web77.hosting-cloud.net:2087
web78.hosting-cloud.net:2087
web79.hosting-cloud.net:2087
web82.hosting-cloud.net:2087
web85.hosting-cloud.net:2087
web86.hosting-cloud.net:2087
web89.hosting-cloud.net:2087
web90.hosting-cloud.net:2087
web92.hosting-cloud.net:2087
web93.hosting-cloud.net:2087
web94.hosting-cloud.net:2087
web95.hosting-cloud.net:2087
web100.hosting-cloud.net:2087
web101.hosting-cloud.net:2087
web102.hosting-cloud.net:2087
web104.hosting-cloud.net:2087
web105.hosting-cloud.net:2087
web106.hosting-cloud.net:2087
web107.hosting-cloud.net:2087
web111.hosting-cloud.net:2087
web113.hosting-cloud.net:2087
web115.hosting-cloud.net:2087
web118.hosting-cloud.net:2087
web120.hosting-cloud.net:2087
web125.hosting-cloud.net:2087
web128.hosting-cloud.net:2087
web133.hosting-cloud.net:2087
web135.hosting-cloud.net:2087
web136.hosting-cloud.net:2087

Resolved
Jul 8, 2026 at 11:16pm UTC

We experienced an issue with cPanel's licensing services, which affected license renewals across all DreamIT cPanel servers.

cPanel provided a fix for the issue, and our team has now applied it across all affected servers. License renewals are now updating normally.

Timeline in AEST:
- Issue first reported: 7:16 AM AEST
- Root cause identified: 7:56 AM AEST
- Mitigation rollout began: 8:07 AM AEST
- Mitigation rollout completed by our team: 8:37 AM AEST

Our team will continue monitoring the situation closely. If you continue to experience any issues, please contact our support team.