We are currently experiencing degraded performance on CP103
Resolved
Jun 17, 2026 at 5:13am UTC
Thank you for your ongoing support and patience.
We have identified that the issue relates to the LiteSpeed web server.
The server has been stabilised, and our team will continue to work with our partner and monitor the server closely.
If you continue to have issues, please reach out to our support team.
Affected services
Created
Jun 15, 2026 at 3:00pm UTC
We’re currently investigating resource-related issues on CP103.
During this time, you may notice slower loading times or intermittent performance for some services.
Our team is working to resolve this as quickly as possible.
We apologise for the inconvenience and appreciate your patience.
We will provide further updates shortly.
Affected services