Back to overview
Degraded

cp103 Degraded performance under investigation

May 25, 2026 at 2:14am UTC
Affected services
cp103.hosting-cloud.net:2222

Resolved
May 25, 2026 at 5:50am UTC

Thank you for your patience.

Our team are happy to advise that this issue has been resolved.

Our server was under a DDOS attack, which has now been mitigated.

We have created additional rules to combat the issue, and we will continue to monitor the service closely.

If you continue to have issues, please raise a support ticket to our team.

Created
May 25, 2026 at 2:14am UTC

We are currently aware of degraded performance on cp103.hosting-cloud.net. Our engineers are investigating the issue now.

We apologise for the inconvenience and appreciate your patience while we work to restore normal performance.